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1 Introduction

The basic Netop School user documentation consists of the Netop School Quick Guide,
the Netop School Help and the corresponding Netop School User's Guide.

The quick guide is a brief, illustrated guide that introduces basic Netop School concepts
and features to teachers. The guide is available in print-friendly PDF format.

The Netop School Help aims to provide assistance with daily tasks, primarily for the
teacher but also for the student. Help is available on the Help menu from within the
Teacher and Student modules, by pressing the F1 key and by clicking a Help buttons in a
dialog box. For users who prefer to browse or read help information in hard copy, the help
information is also available in PDF format entitled Netop School User's Guide.

The present document, Netop School Advanced User's Guide, provides technical
guidance for the advanced user or administrator. The document covers these areas:

· Installation

· Start options

· Communication devices

· Advanced tools and features
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2 Install Netop School

Netop School consists of two modules: The Teacher module which is installed on the
teacher’s or instructor’s computer, and the Student module which is installed on the
computers that students are using.

Note

Before you begin the installation, please verify that your hardware and software meet the
technical requirements. Refer to http://requirements.netop.com/.

Install sequence

The recommended installation sequence it to first install the Teacher module and then
install the Student module.

Also, it is recommended to install the Student module on the teacher computer as well. 
Even though the teacher does not need the Student module in the daily work situations,
the Student module is typically installed on the teacher's computer along with the
Teacher module. Installing the Student module as well makes it easier to deploy the
Student module on multiple computers from the teacher's computer.

2.1 Install Teacher and Student

Teacher and Student modules are installed from the Downloads section on the www.
netop.com home page: 

1.Under Downloads, click Software and browse to the Netop School Family page that
lists all versions in the available language.

2. Click the relevant link, for example the one labeled "Netop School Build 2008126
English", to open the specific download page from the specific version and the
specific language.

This page has links to Teacher and Student modules as well as to the documentation in
PDF format.

http://requirements.netop.com/.
http://www.netop.com
http://www.netop.com
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Note

Before you being installing you should have serial numbers readily available for the
Teacher and the Student modules as you will be required to specify these during the
installation process.

2.1.1 Install Teacher module

1.Click the Download Teacher link and click Save to download the installation package
and install from a local computer, or Run to start the installation immediately.

The installation file is called NetopSchoolTeacher_<Language abbreviation>.msi, for
example NetopSchoolTeacher_FR.msi.

2.When the installation is running, follow the installation wizard instructions.

A few notes on the wizard page choices:

On the Customer information wizard page you will be required to type your
Teacher serial number.

On the Setup type wizard page you can choose between these installation
options: Typical, Custom, or Complete. Select Custom if hard disk space is an
issue or if you want to choose a different drive and folder to install to than the
default options.

On the Windows Firewall Configuration wizard page leave the Allow Netop
School to accept incoming network connections check box selected. This is
necessary to set up connections without being disturbed by firewall issues.

On the last wizard page leave the Launch the Netop School Teacher product
check box selected to start the Teacher module immediately.

For information on starting the Teacher module, see Start Netop School.
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2.1.2 Install Student module

Installing the Student module is completely parallel to installing the Teacher module, only
the link text is different and a few of the installation options differ.

As mentioned previously, you will typically install the Student module on the teacher's
computer after the Teacher module has been installed.

1. Click the Download Student link and click Save to download the installation
package and install from a local computer, or Run to start the installation
immediately.

The installation file is called NetopSchoolStudent_<Language abbreviation>.msi, for
example NetopSchoolStudent_FR.msi.

2.When the installation is running, follow the installation wizard instructions.

A few notes on the wizard page choices:

On the Customer information wizard page you will be required to type your
Student serial number.

On the Setup type wizard page you can choose between these installation
options: Typical, Custom, or Complete. Select Custom if hard disk space is an
issue or if you want to choose a different drive and folder to install to than the
default options.

On the Windows Firewall Configuration wizard page leave the Allow Netop
School to accept incoming network connections check box selected. This is
necessary to set up connections without being disturbed by firewall issues.

On the last wizard page leave the Launch the Netop School Student product
check box selected to start the Student module immediately. 

For information on starting the Student module, see Start Netop School.

2.1.3 Deploying Student module from Teacher module

Deploying the Student module from the Teacher module means that you go through these
steps:

1. Install the Student module on the same computer as the Teacher module.

Note

· Installing the Student module on the same computer as the Teacher module is not
a requirement for student deployment but it does make student deployment easier
and more flexible. 

2.Define settings for the Student module.

3. Roll out identical Student modules on all computers to be used by students.

Student deployment has two advantages: all the computers that students are using get
identical setup, and you install from one central computer rather than at each individual
computer.

Requirements for Student deployment:

· The Teacher computer that you run Student deployment from must run on one of these
operating systems: Windows Vista, Windows XP, Windows 2000 or Windows NT.

· The student computers that you deploy to must also run one of these operating
systems: Windows Vista, Windows XP, Windows 2000 or Windows NT.
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· The user who logged on to Windows on the Teacher computer that runs the Student
deployment must have remote installation rights, typically administrator rights, on
computers where the Student is deployed.

Student deployment

1.On the Tools tab, click Student Deployment and follow the wizard instructions.

2.On the Select Student Installation source (MSI file) for deployment wizard page,
click Next and then select the Student .msi file that you want to install.

Typically you will have downloaded this file locally as described in section Install
Student module but not yet run the actual installation.

3.On the Create Student Settings wizard page, select one of the three options. The
first two options require that the Student module has been installed on the computer.

Simplified: Starts the Student module and the Student Setup Wizard within the
module to set up the Student module the way it should be set up on
all student computers.

Exit the Student module when you have completed the Student
Setup Wizard and continue the Student Deployment wizard.

Tip

Select the Simplified option if you are not very familiar with the
Student module and would like to be guided through the setup of all
the standard options.

Advanced: Starts the Student module and opens the Options page to allow you
to open the appropriate dialog boxes and make the necessary setup.

Exit the Student module when you have completed the setup and
continue the Student Deployment wizard.

Tip

Select the Advanced option if you have set up the Student module
previously and are familiar with the setup options.

Existing: Allows you to select basic Student configuration files that were
installed with the Teacher and use those as the basis for the
deployment. 

By default the configuration files are located here: C:\Documents and
Settings\<user>\Application Data\Danware Data\Netop
School\Teacher\StudentNDB.

For additional information about configuration files, see Netop School
configuration files.

Once you have made your selections in the appropriate dialogs, you have created the
Student setup to be deployed to the computers students will be using.

4.On the Start the Netop Pack'n Deploy wizard page, click Next to end the Student
Deployment wizard and open the Netop Pack'n Deploy that allows you to specify
which computers to deploy to.
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Select which computers to deploy to, type your user name and password and click 
Deploy to begin the process. 

· For help on the dialog box options in Netop Pack'n Deploy: on the Help menu click
Help.

When the deployment process is complete, this message displays on the Teacher
computer:

The Student module can now be started on the student computers.

2.2 Change or remove Teacher or Student modules

To change or remove a Netop Teacher or a Netop Student module:

· From the Control Panel, click Add or Remove Programs.

The modules are listed as Netop School Teacher and Netop School Student,
respectively.

Select the appropriate module and click Change or Remove according to your intentions.
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Tip

You can also remove a Netop module using the installation package. When you remove a
Netop module using the installation package, all configuration settings (*.ndb) are
preserved unless you explicitly choose to remove them. 

If you remove a Netop module using Add or Remove Programs from Windows Control
Panel, configuration settings are not removed. 
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3 Start Netop School

Start the Teacher module:

· On Windows Start menu, point to All Programs, Netop School and click Teacher.

Start the Student module:

· On Windows Start menu, point to All Programs, Netop School and click Student.

3.1 The first time you start each of the modules

The first time you start each of the modules, typically right after the installation, the 
Setup Wizard starts. The wizard leads you through the necessary setup options but
default settings have been defined and if you have no changes, just click Next to accept
the default settings.

Student default settings

Startup options for the Student
module

· The Student module automatically joins a class.

· The Student module starts when the computer is
started.

· The Student module appears as an icon in the
notification area.

Daily use options for the Student
module

· The class the Student module should join: My
Class.

· The Student module identification to the Teacher
module: computer name.

Student module communication
with the Teacher module

· Communication profile: TCP/IP.

Teacher default settings

Daily use options for the Teacher
module

· The class name: My Class.

· Feature set: full feature set.

Identification settings for Student
modules

· The display name used on the Teacher computer
to identify each Student computer: Student login
name.

Teacher module communication
with Student modules

Communication profile: TCP/IP.
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Note

The Setup Wizard can be run at any time.

· In the Teacher module: On the Tools tab, in the Teacher group, click Setup Wizard.

· In the Student Module: On the Tools menu, click Run Setup Wizard.

3.2 Alternative startup methods

The Teacher module executable is ntchw32.exe. Depending on your operating system and

installation choices, the file is located here:

C:\Program Files\Danware Data\Netop School\Teacher

The Teacher module can be started by double-clicking the application file. To easily start
up the module, you can create a shortcut to the .exe file on the computer's desktop.

If you want to start the Teacher module from another application, you might want to
start it with the appropriate communication profile and class name. Use the following
syntax:

<path>ntchw32 [/C:<Communication profile>] [/N:<Class name>]

If the class name contains spaces, it must be enclosed within quotation marks.

Example

C:\Program Files\Danware Data\Netop School\Teacher\ntchw32 /C:IPX /
N:"French 7th grade spring term"

The student executable is nstdw32.exe. Depending on your operating system and

installation choices, the file is located here:

C:\Program Files\Danware Data\Netop School\Student

If you want to start the Student module from another application, you might want to
start it with the appropriate communication profile and class name. Use the following
syntax:

<path>nstdw32 [/C:<Communication profile>] [/N:<Class name>]

If the class name contains spaces, it must be enclosed within quotation marks. If any of
the parameters are not used, the parameters that applied when the Student was last run
will be used.

Example

To run the Student module with the IPX communication profile and join a class named
"Geography", use this command line:

nstdw32 /C:IPX /N:Geography

To run the Student module with the communication profile that was last used and join the
class named "French 7th grade spring term", use this command line:

nstdw32 /N:"French 7th grade spring term"
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4 Communication devices

Netop uses the term communication devices for the Netop adaptations of general
communication protocols and the Netop proprietary protocols developed for Netop
applications.

Netop modules use different configurations of communication devices for communicating
with other Netop modules in different environments. Such Communication device
configurations that are given individual names are called communication profiles.

While a range of default communication profiles are included when a Netop module is
installed for the first time, users will typically want or need to create new communication
profiles that are optimized for their environment.

This section explains about communication devices and about how Netop communication
profiles are created and managed.

· In the Teacher module: On the Options tab, in the Advanced group, click Connection
and then click New.

· In the Student module: On the Tools menu, click Options. Double-click Connection
and then click New.

Use the dialog box to create or edit a communication profile with this information:

Option Description

Description of
Communication Profile

If you are creating a new profile, the field is empty. If you
are editing an existing profile, the field shows the name of
the selected Communication profile.

Specify a profile name or edit the existing if appropriate.

Communication Device List of available communication devices that for Netop
School, including:

· NetBIOS

· IPX

· TCP/IP
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Option Description

· Terminal Server (available only on Netop modules that
run on a terminal server). 

Use Dial-Up Networking This field is available only if TCP/IP is selected in the
Communication Device list. Select the check box to
enable creating or editing a connection via modem to a
network.

The lower window section will be named by the communication device selection and have
different contents with different selections. 

4.1 TCP/IP

TCP/IP (Transmission Control Protocol/Internet Protocol) is a suite of widely used network
communication protocols. Netop School uses a Netop adapted version of the TCP/IP suite
networking protocol UDP (User Datagram Protocol) named TCP/IP.

Netop School utilizes the ability of UDP to send and receive name identified by Broadcast
communication on a local IP network segment. UDP can also send and receive IP address
and DNS name addressed by Unicast communication across large segmented IP networks
including the Internet. This combination of local network segment Broadcast
communication and remote network segments Unicast communication enables running
physical classes on a local network segment as well as virtual classes on a large network
or on the Internet.  

4.1.1 TCP/IP settings

To use TCP/IP communication:

· In the Teacher module: On the Options tab, in the Advanced group, click Connection
and select or create a communication profile that uses TCP/IP.

· In the Student module: On the Tools menu, click Options. Double-click Connection
and select or create a communication profile that uses TCP/IP.

Identification

Teachers identify themselves to Students by their running class name.

Students identify themselves to Teachers by their Student login name, Windows login
name and Computer name. 

Computers identify themselves by one or multiple IP addresses and a DNS name.

Netop School TCP/IP communication identifies Teachers and Students by their names and
IP addresses.

Communication problems

If Netop School modules do not communicate as expected, use these diagnostic tools:

· Verify that an IP connection is available between computers by using the PING utility
as explained below.

· Read the TCP/IP communication profile edit section and verify that all required
specifications are in place.
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· Read the Netop School communication section. 

As a last resort, submit a support request by using the Support for Netop Products form
on the www.netop.com homepage.

PING utility

To verify that an IP connection is available between two computers across a network
using TCP/IP, on one computer from a command prompt type:

PING <Other computer IP address>

The PING utility will send four data packets that request a reply. If replies are received,
an IP connection is available.

Ports

Netop modules can use one TCP/IP port for sending and receiving communication.

We generally recommend that you use port number 1971 that is officially registered to
Netop School.

In special situations, you can use other port numbers but remember that the Teacher
send port number must always match the Student receive port number and vice versa.

4.1.2 TCP/IP Communication Profile Edit

Below illustration is the Communication Profile Edit dialog box when Communication
Device is TCP/IP and the Use Dial-Up Networking check box has  been selected:

For details about the Communication Information group, refer to the Communication
devices section.

The other dialog box options are described below.

http://www.netop.com
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Option Description

Dial-Up Network
Profile

Select a previously defined dial-up network profile.

Dialing from and Calling card show dialing properties. 

Click Configure or Dialing Properties to modify an existing
profile, or Add Profile to create a new.

Max packet size
(MTU)

Specify the maximum data packet size.

MTU is an acronym for Maximum Transmission Unit and defines
the maximum packet size that can be transmitted. If more data
needs to be transmitted, data is automatically split into several
packets by the communication router. This is generally not a
problem as long as the initialization packet is not split up but can
be transmitted as one. The necessary initialization packet size is
defined by the number of student computers: 8 bytes times the
number of student computers or 400 bytes for 50 student
computers.

MTU is hardware dependent and should match the available
hardware. 

If you experience communication issues, review the hardware
specifications to investigate whether the MTU can be increased
in Netop School. Generally a large packet size will improve
communication. If the hardware can handle only a small packet
size, make sure that:

· The packet size is larger that required for the Netop School
initialization packet (= 8 bytes * number of students). If the
max packet size that can be handled by the hardware is
smaller than the required initialization packet, either decrease
the number of students or replace the hardware.

· The hardware is capable of splitting up large packets. If the
hardware cannot split up packets, it might be necessary to
replace the hardware.

Optimize for Internet
communication

Select this option to optimize MTU, compression and cache
memory for communicate across the Internet. 

When the Optimize for Internet communication check box is
selected, MTU is set to 1028 bytes.

Advanced TCP/IP configuration

In the TCP/IP Communication Profile Edit dialog box, click Advanced to open the
dialog box below:
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Option Description

Specify IP address Select the Use all available IP addresses check box to use all
of the computer's IP addresses for this communication profile's
communication.

Clear the Use all available IP addresses check box to use only
one IP address and type the address to be used.

Specify port numbers Select the Use default port numbers check box to use the
official Netop School port number 1971 for Receive port and
Send port. 

Clear the Use default port numbers check box to type
different port number.

Note

· Except for special situations, we recommend using the official
port number. Remember that the Teacher Send port number
must match the Student Receive port number and vice versa.

Netop Name Server Clear the Use Netop Name Server check box to connect
without using Netop Name Management. For more information,
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Option Description

see the Netop Name Management section. 

Select the Use Netop Name Server check box to connect
swiftly across large segmented networks including the Internet.
In the Primary text box, type nns1.netop.com to use the
default Netop Name Server, or specify a local name server, if
available. In the Secondary text box, type nns2.netop.dk to
use the default secondary Netop Name Server, or specify a local
name server, if available.

Select Ignore port information from Name Server to replace
the destination module Receive port number received from Netop
Name Server by the port number specified below.

Note

· Some types of firewalls replace sent Receive port numbers by
invalid port numbers to protect network computers against
connection attempts. In that case, Netop Name Server will
receive, store and return invalid Receive port numbers that
must be replaced by valid Receive port numbers.

Unicast This option is available on the Teacher module only.

Select the Enable check box to supplement broadcast
communication with unicast communication to each Student.

Multicast This option is available on the Teacher module only.

Select the Enable check box to supplement broadcast
communication with multicast communication via multicast
routers. And then select one of these options:

Automatic - let Netop specify a multicast IP address.

Specify - specify a multicast IP address.

IP Broadcast List

In the TCP/IP Communication Profile Edit dialog box, click IP Broadcast List to open
the dialog box below:
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For TCP/IP broadcast communication to reach computers on remote network segments
computer when Netop Name Management is not used, IP addresses or DNS names must
be listed the IP broadcast list.

Click Add to open a dialog box to add a DNS name or IP addresses:

Specify an IP address, IP address range or DNS name and click OK.

Note

Specifying an IP address range will send individual packets to all IP addresses in the
specified range. To avoid excess network traffic, do not specify a larger IP address range
than required.

Select the Disable local subnet broadcast check box to disable broadcast
communication to local network segment computers.

4.2 Terminal Server

Terminal Server is a Netop proprietary communication device that is available only on
Netop modules installed on a Windows terminal server.

Netop School Teacher and Student installed on a terminal server can run in client
sessions. Each client session Teacher can communicate with client session Students using
a Terminal Server communication profile.

A Netop Gateway that runs on the terminal server console can route communication
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between client session Netop School modules and Netop School modules that run on
network computers or other terminal servers.

Note

For information about installing, setting up and running Netop School in terminal server
environments, see the Netop School in terminal server environments section.

4.2.1 Terminal Server Settings

To use Terminal Server communication: 

· In the Teacher module: On the Options tab, in the Advanced group, click Connection
and select or create a communication profile that uses Terminal Server.

· In the Student module: On the Tools menu, click Options. Double-click Connection
and select or create a communication profile that uses Terminal Server.

Identification

Teachers identify themselves to Students by their running class name.

Students identify themselves to Teachers by their Student login name, Windows login
name and Computer name. 

Note

All Teachers and Students on a terminal server share the same computer name.

Terminal server client sessions identify themselves by the Windows login name of the user
logged in to the terminal server.

Netop School Terminal Server communication identifies Teachers and Students by their
names.

Communication problems

If Netop School modules do not communicate as expected, use these diagnostic tools:

· Read the Netop School in terminal server environments section that explains the
particulars of installing, setting up and running Netop School on a terminal server.

· Read the Netop School communication section. 

As a last resort, submit a support request by using the Support for Netop Products form
on the www.netop.com homepage.

Resources

When Netop School is properly installed on a terminal server, the required resources are
available.

http://www.netop.com
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4.2.2 Terminal Server Communication Profile Edit

Below illustration is the Communication Profile Edit dialog box when Communication
Device is Terminal Server:

For details about the Communication Information group, refer to the Communication
devices section.

There are no options or settings for Terminal Server communication profiles.

4.3 IPX

IPX (Internetwork Packet Exchange) is a networking communication protocol developed by
Novell. IPX is typically used in network environments with NetWare servers and clients.

Netop School utilizes the ability of IPX to send and receive name identified broadcast
communication on a local network including interconnected Novell networks. This enables
running physical classes on a local network as well as virtual classes across
interconnected Novell networks.

4.3.1 IPX Settings

To use IPX communication:

· In the Teacher module: On the Options tab, in the Advanced group, click Connection
and select or create a communication profile that uses IPX.

· In the Student module: On the Tools menu, click Options. Double-click Connection
and select or create a communication profile that uses IPX.

Identification

Teachers identify themselves to Students by their running class name.

Students identify themselves to Teachers by their Student login name, Windows login
name and Computer name. 

Computers identify themselves by the MAC address of their network card. A MAC address
consists of 0x followed by a 12 digit hexadecimal number, for example 0x080005AF341A.

Netop School IPX communication identifies Teachers and Students by their names and
computer network card MAC address.

Communication problems

If Netop School modules do not communicate as expected, use these diagnostic tools:
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· Read the "Finding network numbers" section below and the IPX communication profile
edit section to identify and specify the network numbers of modules located on remote
networks.

· Experiment with the netop.ini setting as explained below.

· Read the Netop School communication section. 

As a last resort, submit a support request by using the Support for Netop Products form
on the www.netop.com homepage.

Finding network numbers

To find the network number for a computer with a known name, type one of the
commands below from a command prompt:

nlist user=<Name> /a (NetWare 4.x) 

userlist /a (NetWare 3.x)

If you are attached to a NetWare server that recognizes the name, it will respond with
the network number in the address field.

Netop.ini setting

This setting can be used in a netop.ini file [IPX] section:

Key Value Explanation

Max_Packet_Siz
e=

<Number> The number specifies the maximum packet size in
bytes. If you encounter communication problems, try
reducing the maximum packet size to the minimum 512
bytes.

Resources

Netop School uses IPX socket 8641 (hex) when communicating between a Teacher and a
Student.

Novell has assigned this socket to Netop.

http://www.netop.com
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4.3.2 IPX Communication Profile Edit

Below illustration is the Communication Profile Edit dialog box when Communication
Device is IPX:

For details about the Communication Information group, refer to the Communication
devices section.

The other dialog box options are described below.

In the Novell networks group, select one of the options below:

Option Description

Local network only Communicate to the local network only.

User defined list of
networks

Enables the Network list button. Click it to show the Novell
network numbers dialog box:
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The pane will show 8-digit hexadecimal network numbers of remote
networks.

Build list of known
networks

Let the Netop module browse the network to build a list of known
networks to enable communication to these networks.

4.4 NetBIOS

NetBIOS (Network Basic Input/Output System) is a simple networking communication
protocol for local area network communication.

Netop School utilizes the ability of NetBIOS to send and receive name identified Broadcast
communication on a local network segment. Communication that uses NetBIOS in its basic
mode (in Windows: Microsoft NetBEUI) cannot pass network connection elements like
routers. Communication that uses NetBIOS over IPX or TCP/IP can pass network
connection elements. Communicating modules must use the same NetBIOS mode. Different
NetBIOS modes use different NetBIOS adapter numbers.

4.4.1 NetBIOS Settings

To use TCP/IP communication:

· In the Teacher module: On the Options tab, in the Advanced group, click Connection
and select or create a communication profile that uses NetBIOS.

· In the Student module: On the Tools menu, click Options. Double-click Connection
and select or create a communication profile that uses NetBIOS.

Identification

Teachers identify themselves to Students by their running Class name.

Students identify themselves to Teachers by their Student login name, Windows login
name and Computer name. 
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Computers identify themselves by the MAC address of their network card. A MAC address
consists of 0x followed by a 12 digit hexadecimal number, e.g. 0x080005AF341A.

Netop School IPX communication identifies Teachers and Students by their names and
computer network card MAC address.

Communication problems

If Netop School modules do not communicate as expected, use these diagnostic tools:

· Verify that Teacher and Student use the same NetBIOS mode; see the NetBIOS
communication profile edit section.

· Experiment with the netop.ini settings explained below.

· Read the Netop School communication section. 

As a last resort, submit a support request by using the Support for Netop Products form
on the www.netop.com homepage.

Netop.ini settings

These settings can be used in a netop.ini file [NetBIOS] section:

Key Value Explanation

Max_Packet_Size
=

<Number
>

The number specifies the maximum packet size in bytes. If
you encounter communication problems, try reducing the
maximum packet size to the minimum 512 bytes.

Rcv_DG_Threads= 1 or 2 By default, Netop uses 2 datagram threads. Under certain
circumstances, 2 datagram threads cause problems, and 1
can be specified.

Resources

No particular resources are used by the NetBIOS communication device.

4.4.2 NetBIOS Communication Profile Edit

Below illustration is the Communication Profile Edit dialog box when Communication
Device is NetBIOS:

For details about the Communication Information group, refer to the Communication
devices section.

http://www.netop.com
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The other dialog box options are described below.

Option Description

Adapter number Specify the NetBIOS adapter number.

Click List to display available NetBIOS modes:

Number: Adapter number.

Description: Mode description.

Version: Software version number.

Type: Software type.

Max packet size: Maximum packet size in bytes.

MAC address: Network adapter MAC address.

Note

· The information is retrieved from Windows. Valid mode records will show
the computer network card MAC address. The table may contain other
records with random MAC addresses. They are invalid and should be
disregarded.

Select line and click OK to enter the adapter number in the Adapter
number field.
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5 Advanced tools and features

This chapter describes tools that are of interest mainly to system or network
administrators.

The chapter includes these sections:

· Netop.ini

· Netop configuration files

· Netop School communication

· Netop School in terminal server environments

· Netop name management

· Netop School class management

· System info

· Policies

5.1 Netop.ini

Installing a Netop program on a computer for the first time will create a netop.ini file in
the Windows (or WINNT) folder.

Netop.ini will be read when a Netop program is installed on the computer to determine
among other things the default installation folder and program folder and will automatically
be updated with each additional Netop program installation.

Netop.ini will be read when a Netop module is loaded. It can contain special setup
information that will be applied to the Netop module.

Typically, you do not need to worry about netop.ini but you can edit it to provide desired
installation and loading options.

Netop.ini uses the standard Windows .ini file format with sections, keys and values. It is a
plain text file that can be opened and edited in a standard text editor:
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Netop.ini can contain the sections:

· [INSTALL]: Always included. Specifies Installation settings.

· [COEXISTENCE]: Always included. Specifies settings for running different Netop modules
on a computer at the same time.

· [TEACHER]: Optional. Specifies Teacher settings. 

· [STUDENT]: Optional. Specifies Student settings.

· [IPX]: Optional. Specifies IPX settings.

· [NetBIOS]: Optional. Specifies NetBIOS settings.

· [DTL]: Optional. Specifies communication settings.

Other optional sections can be included in netop.ini.

Note

The www.netop.com website Support section KnowledgeBase section Documentation
section netop.ini settings section explains available netop.ini settings.

http://www.netop.com
http://help.netop.com
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5.1.1 [INSTALL] section

The netop.ini file  [INSTALL] section will contain keys that specify the folder path and
program folder name of the most recently installed Netop programs. These Netop School
keys are typically included:

SCHOOL_DIRECTORY=C:\Program Files\Danware Data\

SCHOOL_FOLDER=Netop School

TEACHER_DIRECTORY=C:\Program Files\Danware Data\Netop School\Teacher\

STUDENT_DIRECTORY=C:\Program Files\Danware Data\Netop School\Student\

The values of these keys are the default suggestions when reinstalling Netop programs.

5.1.2 [COEXISTENCE] section

The netop.ini file always included [COEXISTENCE] section will contain keys that specify if
different Netop programs can be loaded on the computer at the same time.

It can contain these keys:

COEXIST=<0, 1 or 2> This key will always be included.

The value 0 will not allow loading a Netop module if another
Netop module is loaded.

The value 1 will allow loading a Netop module temporarily
suspending a loaded different Netop module. A Student
connected to a Class cannot be suspended.

The value 2 will allow loading a Netop module while a different
Netop module is loaded.

LOAD_WARNING=<0 or 1> This key is optional.

The value 0 will not show a warning message.

The value 1 or no key will show a warning message that
enables the user to accept or deny temporarily suspending a
loaded module to load another module if COEXIST has the
value 1.

DEBUG=<0 or 1> This key is optional.

The value 0 or no key will hide a window that shows the
loader program commands executing.

The value 1 will show a window that shows the loader program
commands executing.

Note

If two Netop modules run on a computer at the same time, they must use different 
Communication device settings (with TCP/IP different port numbers).
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5.1.3 [TEACHER] section

The netop.ini file optional [TEACHER] section can contain keys that modify certain
Teacher properties.

It can contain these keys:

DATAPATH=<Path> Teacher User configuration files will be stored in
the specified <Path> instead of their default
location.

LESSONPATH=<Path> Teacher Lesson plan files will be stored in the
specified <Path> instead of their default
location.

POLICYPATH=<Path> Teacher Policy files will be stored in the
specified <Path> instead of their default
location.

RECORDPATH=<Path> Teacher Recording files will be stored in the
specified <Path> instead of their default
location.

SNAPSHOTPATH=<Path> Teacher Print screen to file files will be stored in
the specified <Path> instead of their default
location.

TESTPATH=<Path> Teacher Test files will be stored in the specified
<Path> instead of their default location.

SURVEYPATH=<Path> Teacher Survey files will be stored in the
specified <Path> instead of their default
location.

BLOCKPATH keyBLOCKPATH=<URL path> This key will store a Teacher Options window
Sharing tab Blocking page specified URL path.

Note: You can use environment variables in the
<Path> parameter.

Max_Students=<Number> A number between 5 and 200 will specify the
maximum number of Students in a Class. Default
is 50.

5.1.4 [STUDENT] section

The netop.ini file optional [STUDENT] section can contain keys that modify certain
Student properties.

It can contain this key:

DATAPATH=<Path> Student User configuration files will be stored in the specified
<Path> instead of their default location.
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5.1.5 [IPX] section

The netop.ini file optional [IPX] section can contain keys that modify certain IPX
properties.

It can contain this key:

Max_Packet_Size=<Number> A number between 512 and 5000 will specify the maximum
data transmission packet size in bytes.

5.1.6 [NetBIOS] section

The netop.ini file optional [NetBIOS] section can contain keys that modify certain
NetBIOS properties.

It can contain these keys:

Max_Packet_Size=<Number> A number between 512 and 5000 will specify the maximum
data transmission packet size in bytes.

RCV_DG_THREADS=<1 or 2> 1 or 2 will specify the number of received datagram
threads.

5.1.7 [DTL] section

The netop.ini file optional [DTL] section can contain keys that modify certain
communication properties.

It can contain these keys:

MinTimeOut=<Number>

MaxTimeOut=<Number>

Each of these keys will replace Netop’s automatic calculation
of minimum or maximum waiting time for receiving an
acknowledgement of data packet reception by the specified
number of tics (1/18 second).

TimeOutTimes=<Number> A number between 1 and 50 will add this number of timeout
attempts to the default 10.

Use these keys to overcome communication problems in
crowded networks where data packets take a long time to get
through or get lost.

5.2 Netop configuration files

The setup of Netop modules is stored in configuration files, typically with the extension .
ndb.

When a Netop module is installed on a computer, its setup will be stored in Installed
configuration files in the folder where the Netop module is installed.

When a user loads a Netop module for the first time after it was installed, installed
configuration files will be copied to a user folder to serve as User configuration files.

Unless the Netop module is installed in a fully set up state by deployment, the Setup
wizard will run for the user to create a customized setup, the settings of which will be
written to the User configuration files.
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Folders for other Netop files created by the user will be created in the User configuration
files folder.

Netop log files created by the user will be saved in the user configuration files folder.

This table provides an overview of Netop School configuration and other files, their
location and content:

File name Location File content

Common files

comiplst.ndb <Teacher> and
<Student>

IP broadcast list

comprof.ndb <Teacher> and
<Student>

Communication profiles

Teacher files

classrms.ndb <Teacher> Classes

config.xml <Teacher> Teacher Ribbon definition

locstd.ndb <Teacher> Student file locations

loctch.ndb <Teacher> Teacher file locations

nowconf.ndb <Teacher> Teacher setup

runprog.ndb <Teacher> Run program specifications

stdgrps.ndb <Teacher> Student groups

stdinfo.ndb <Teacher> Student information

teachers.ndb <Teacher> Teacher profiles

*.log, *.rlg <Teacher>\DeployLog Student deployment logs

*.xml <Teacher>\Lessonpl Lesson plans

*.xml <Teacher>\Policies Policies

*.dwr <Teacher>\screcord Recordings

*.ndb, setup.
iss

<Teacher>\StudentND
B

Student deployment setup files

*.nxt, *.nxs,
*.nxr

<Teacher>\Tests Tests, surveys, results

Student file

nhstconf.ndb <Student> Student setup

The meanings of <Teacher> and <Student> are explained in the Location of user
configuration files section.

When a user changes the setup of a Netop module during use, changes will be written to
the User configuration files immediately or when the Netop module is unloaded.

When a user loads a Netop module, the User configuration files will be read to re-establish
the setup that existed when the user last unloaded the Netop module.
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If User configuration files are write protected or access to the folders in which they reside
is denied, user setup changes cannot be written to files and will not be retained.

The setup of a Netop School module can be protected by applying a Protection password.
Student User configuration files can be protected when the Student is connected to a
Class or has Joined class.

If User configuration files are deleted, the user setup of deleted User configuration files
will be lost. When the module is loaded after deleting User configuration files, a new user
setup in new User configuration files will be created.

Most configuration files are written in a Netop proprietary format that cannot be read or
edited separately.

5.2.1 Location of user configuration files

If user profiles are implemented on the computer, Teacher user configuration files will by
default be stored in user folder of the user logged in to Windows. Student user
configuration files will by default be stored in the All users (Vista: ProgramData) folder.

On Windows Vista, user folders are typically C:\Users\<Windows login user name>.

On Windows XP, user folders are typically C:\Documents and settings\<Windows login
user name>.

By default, user configuration files will reside in the path <User folder>\Application
data\<Netop module path>, where <Netop module path> is the full path to the folder in
which the Netop module is installed. If the Netop module is installed in the C:\Program
files folder, only the path from that folder is used in <Netop module path>.

Note: Application data is a hidden folder. To show it and its contents, on the Windows
folder options window View tab select Show hidden files and folders.

If user profiles are implemented, this is the meaning of <Teacher> and <Student> in the
Netop configuration files section table.

If user profiles are not implemented using Windows ME, 98 or 95, User configuration files
will by default reside in a Config folder in the folder in which the Netop module is installed.

Alternative locations

You can store Netop user configuration files and other user created files in other user
individual or general locations by specifying some or all of these keys in the netop.ini file:

[TEACHER]

DATAPATH=<Path>

LESSONPATH=<Path>

POLICYPATH=<Path>

RECORDPATH=<Path>

SNAPSHOTPATH=<Path>

TESTPATH=<Path>

SURVEYPATH=<Path>

and/or

[STUDENT]

DATAPATH=<Path>
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- where <Path> is the full path to the folder in which User configuration files or other user
created files shall be stored.

In this case, this is the meaning of <Teacher> and <Student> in the Netop configuration
files section table.

5.3 Netop School communication

By default Netop School uses two different types of communication between Teachers
and Students, namely broadcast communication and unicast communication. To optimize
communication, broadcast is the preferred method but NetOp School will automatically
switch to direct (unicast) communication to a Student if it is detected to be more
effective for a while.

If your routers are set up to use multicast, Netop School can be configured to use that
method as default. 

Tip

We have seen dramatic improvements in communication (factor 5) on wireless access
points using multicast communication.

Broadcast communication 

Broadcast communication will communicate to all reachable recipients. 

Broadcast communication will reach local network computers but will typically not pass
routers and other network connection elements to reach remote network computers. 

Using TCP/IP, local broadcast communication can be extended by sending the same
communication by unicast communication to individual IP addresses and/or DNS names of
computers beyond the local network specified in an IP broadcast list or received by using
Netop Name Server.
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Multicast communication

Multicast is a network addressing method for the delivery of information to a group of
destinations simultaneously using the most efficient strategy to deliver the messages over
each link of the network only once, creating copies only when the links to the multiple
destinations split (typically network switches and routers). 

Unicast communication

Unicast communication will communicate to a specific recipient. 

Initial unicast communication must contain destination computer or terminal server client
session identification. TCP/IP identifies computers by their IP address or DNS name.
Terminal server identifies client sessions by their Windows login user name. IPX and
NetBIOS identify computers by their MAC address.

Responses to broadcast communication and unicast communication will be sent by unicast
communication that can pass the network connection elements passed by the
communication responded to. 

Netop unicast communication will (unless being extended Broadcast communication)
request a communication receipt acknowledgement returned to the sender.

Netop School uses broadcast communication for these actions:

Announcement
An announcement is broadcast communication that does not
request a response.

When a Teacher module starts with a class name, reannounces a
class, changes class or exits, it will send an announcement.

· A Student module waiting for the announced class will return
unicast communication to connect to the class.

· In response to a class announcement, a Student module that is
available will return unicast communication stating its status,
which will add the Student in the available students pane. If the
responding Student is a member of the class, the Teacher will
request the Student to connect by unicast communication. The
student will then connect using unicast communication.

· If a connected Student module receives an announcement that
the Teacher changes class or exits, the Student will disconnect.

When a Student module with the option Be available for any
Class set becomes available, the Student module will send an
announcement.

· A Teacher module that runs a class will add the Student in the
available students pane.

· A Teacher module that runs a class where the Student is a
member will request the Student to join by unicast
communication. The student will then connect using unicast
communication.

When a Student changes state from being available to no longer
being available, the Student module will send an announcement.

· A Teacher module that runs a class, the announcement will
removed the Student from the available students pane.
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Browse
A browse is broadcast communication that requests a response
from specified recipients.

When a Student module with the option Browse for Classes set
joins a class, the Student module will send a broadcast
communication that requests a response from Teachers that run a
class. Teachers that run a class will respond by unicast
communication to enable Students to build a list of available
classes. If the Student selects a class in the list and clicks OK,
the Student will join by unicast communication.

When a Student module with the option Connect to class: <class
name> set joins a class, the Student module will send a
broadcast communication that requests a response from the
Teacher that runs the class specified by <class name>. If the
Student receives a response, the Student module will connect by
unicast communication. If the Student does not receive a
response, the Student module will be in status Waiting for <class
name> and can respond to a Teacher's announcement of the
specified class.

Most other Netop School communication, including in class communication, will be by
unicast communication.

5.4 Netop School in terminal server environments

You can install Netop School on a Windows terminal server to run classes between 
Teachers and Students in client sessions in a terminal server environment. 

A Netop Gateway that runs on the terminal server console can route communication
between client session Netop School modules and Netop School modules that run on
network computers or other terminal servers to run classes in a mixed terminal server and
network environment.

This section will explain the particulars of Netop School in a terminal server environment in
these sections:

· Installation

· Teacher and student setup

· Netop Gateway setup

· Teacher commands that work differently

5.4.1 Installation

On a terminal server, you cannot install by running the product .msi file:

1.On Windows' Start menu, click Control Panel and then double-click Add or Remove
Programs.

2. Click Add New Programs and browse for the appropriate .msi.

You should install both Teacher and Student modules.

To enable communicating with Teachers and Students outside the terminal server, you
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should also install Netop Gateway.

5.4.2 Teacher and Student setup

Teacher setup

When a user in a terminal server client session loads the Teacher for the first time after
installation, the Teacher Setup wizard will run for the user to create an initial personal
Teacher setup. 

In the Class management window, select Windows login name to initially use this
name option for the Student display name because all Students in a terminal server
environment share the same Computer name.  

In the Communication profile window, select Terminal server to enable communicating
in the terminal server environment.

The Teacher user configuration files and user created files will be stored in the user's user
profile folder on the terminal server to apply when loading the Teacher from the user's
terminal server client session.

Student setup

When any user in a terminal server client session loads the Student for the first time after
installation, the Student Setup wizard will run for the user to create an initial general
Student setup.

In the Classroom window, click the preferred class connect option and in the Identify
student by list, select an option that is not based on the computer name because all
Students in a terminal server environment share the same computer name.

In the Communication profile window, select Terminal server to enable communicating
in the terminal server environment. Note that Terminal server is available as an option
only if you are running on a Terminal server.

The Student user configuration files will be stored in the All Users folder on the terminal
server to apply when any user loads the Student from a terminal server client session.

Protected student setup

To apply a uniform protected Student setup that will prevent Student users from
changing the Student setup to disrupt the class environment, an administrator should set
up the Student with maximum Protection password protection before other users are
allowed to load the Student.

Individual student setup

In other teaching environments, you may prefer to apply an individual Student setup for
each user.

To store Student user configuration files in each user's user profile folder on the terminal
server, assuming that the Student is installed in its default folder, add this line in the
terminal server netop.ini file [STUDENT] section:

DATAPATH=%USERPROFILE%\Application Data\Danware Data\Netop School\Student\

5.4.3 Netop Gateway setup

To enable communication between Teachers and Students that use terminal server and
Teachers and Students that do not, a correctly set up Netop Gateway must be running
on the terminal server console.
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Netop Gateway is an extended Netop Remote Control Host with the capability to route
communication between different communication devices.

With Netop School in a terminal server environment, the task is to route between inside
terminal server environment communication that uses the Terminal server Communication
device and outside terminal server environment communication that uses typically the
TCP/IP communication device.

Netop Gateway setup in general is explained in the Netop Remote Control documentation
that is available with Netop Gateway. Pay special attention to the following:

· Set up Netop Gateway from the terminal server keyboard, mouse and screen (the
terminal server console).

· Be sure to observe the Netop net number rules, particularly if multiple terminal servers
are connected to the same network.

The Netop Net number allocated to any networking communication profile using a
specific communication device must be the same on all Netop Gateways in the
network. 

The Netop Net number allocated to any Terminal Server communication profile on any
Netop Gateway must be different from the Netop Net number allocated to any
communication profile on any Netop Gateway on the network. 

· When installed, Netop Gateway will typically specify the Netop Remote Control default
port number 6502 (in the Advanced TCP/IP configuration window). Be sure to change
it to your Netop School port number, typically 1971.

· If Teachers and Students running on one terminal server are to communicate with
Teachers and Students running on another terminal server connected to the same
network, add these keys to the netop.ini file [DTL] section on both terminal servers:

GWRestrictedBroadcast=0

GWAllowFullBroadcast=1

Routing communication through two Netop Gateways across a network is generally
disabled because in some setups it can cause an uncontrolled propagation of network
traffic (broadcast storm). These keys will safely enable communication through two 
terminal server environment Netop Gateways across a network.

5.4.4 Teacher commands that work differently

In most respects Netop School has the same functionality in a terminal server
environment as in a network environment. However, some Teacher commands work
differently:

· Log off, Restart and Shut down will log off the Student user from the terminal server
client session.

Note

The same commands executed on a Student that runs on the terminal server console will
execute like in a network environment affecting the entire terminal server.

5.5 Netop Name Management

Use Netop Name Management to connect swiftly between networked Teachers and
Students across large segmented networks including the Internet without the need to
specify destination addresses in an IP broadcast list.
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Netop Name Management runs using Netop Name Server. Netop Name Server that is an
extended Netop Remote Control Host with the capability to resolve the names of Netop
modules that communicate using the TCP/IP Communication device into their IP address.

To use Netop name management

1. In the Advanced TCP/IP configuration window, select Use Netop Name Server
and in the Primary and Secondary text fields, specify the DNS name or IP address
of the Netop Name Servers you are going to use. 

2. In the Teacher or Student Connection Options window (on the Options tab, click
Connection) in the Name space ID field, specify the up to 32 characters word that
identifies your private name space. 

All Teachers and Students that connect by Netop Name Management must specify the
same Netop Name Servers and Name space ID.

When you connect by a Class or Student name, Netop Name Server will resolve it into its
matching IP address by which you will connect.

Two Netop Name Servers with the DNS names nns1.netop.com and nns2.netop.dk run
permanently on the Internet for public use. Your private Name space ID will ensure full
privacy. Netop Name Server is also available for private installation.

When a Netop module that uses Netop Name Management starts communicating (Teacher
loads running a class, Student joins class), it will send its names and IP address to Netop
Name Server to enable resolving names into the matching IP address. To ensure that the
stored information is always up to date, Netop Name Server will request renewal of the
information every few minutes and delete information that is not renewed.

For details about Netop Name Management, see www.netop.com:

1.Under Support, click Knowledgebase.

2. Click Documentation and then click Manuals.

Netop Name Management documentation is included in the Netop Remote Control
Administrator's manual.

5.6 Netop School Class Management

Netop School Class Management provides centralized control of a teaching organization's
Netop School classes.

Netop School Class Management consists of these elements:

Netop Class Server: A Netop Remote Control Host with the added capability of providing
class information from a central class database to Teachers and
Students.

Class database: A database server with a class information database.

Netop Class
Manager:

A database client application by which you can create and manage
the class database.

Teachers and Students interact with Netop School Class Management as illustrated in this
diagram:

http://www.netop.com
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Diagram explanation

1a./1b. Request class
information:

When Teachers load and Students join class, and after they
end a class, they will request class information from Netop
Class Server. 

Teacher users can request class information at any time.

2. Query class database:  Netop Class Server will query the class database for
requesting Teacher and Student class information.

3a./3b. Return class
information:

Netop Class Server will return this class information to
requesting Teachers and Students.

4. Connect: Teacher users can select an available class to run it.
Students can be set up to:

· Connect to or wait for a running class to which they are
assigned, or

· Enable the user to select a running, upcoming or generally
available class to connect to or wait for it, or select to be
available for any  class.

Netop School Class Management can run in one of two modes:

Non-scheduled mode: Teachers and Students will be assigned to courses. Netop
School class management will not schedule course classes.
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Teachers can run classes of courses to which they are
assigned, typically according to a schedule specified outside
Netop School class management. Students will or can
connect to classes of courses to which they are assigned.

Scheduled mode: Teachers and Students will be assigned to courses. Netop
School class management will schedule course lessons in
classrooms, typically on a weekly basis. Teachers and
Students will or can connect in classes according to this
schedule.

Netop School class management including Netop Class Server and Netop Class Manager is
available for installation on a teaching organization's network.

For details about Netop Class Management, see www.netop.com:

1.Under Support, click Knowledgebase.

2. Click Download Products and then click Netop School.

3. Click the current Netop School version in your preferred language to show available
download options and under Netop School Class Server, click Manual (PDF) to
download the current Netop School class management user's manual.

5.7 System Info

Detailed system information is available both from the Student and from the Teacher
module: 

· In the About Netop School Student or the About Netop School Teacher window,
click System info:

It shows various system information in these elements:

http://www.netop.com
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· The upper section shows summary program and system information.

· The middle section shows summary screen information.

· The lower section shows summary driver information.

It has these menus:

Click a command to show detailed
screen display information in a 
Screen info window.

Click Net Addresses to show this
window:

The list shows enabled computer
network addresses.

Teacher network addresses will be enabled when the Teacher runs a class. Student
network addresses will be enabled when the Student has joined a class (is
communicating).

5.8 Policies

A policy in Netop School defines which programs student computers can use and which
Internet sites student computers are allowed to visit. 

When two or more policies have been defined, they can be applied to student computers
in combination. The following section described the principles for combining policies.

Please refer to the Netop School Help for details about defining policies.

5.8.1 Principles for combining policies

When policies are combined, the main principle is that the most restrictive policy rule
always wins: Deny wins over Allow.

This means that if a "Deny All" and an "Allow All" policy are combined, then the "Deny
All" policy wins. For example, if a policy is defined as "deny the use of all applications
except Word, Excel, and PowerPoint" (=Word, Excel and PowerPoint are allowed) is
merged with a policy defined as "allow the use of all applications except PowerPoint
(=all are allowed, PowerPoint is denied), then the result is "deny the use of all
applications except Word and Excel".
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Another combination principle is that negative exceptions are intersected with positive
exceptions. Another level of deny wins over Allow.

This means that if an "Allow All" policy with a list of exceptions is combined with a
"Deny All" policy with a list of exceptions, then first of all the policy becomes a "Deny
All" policy (according to the main principle above) and secondly the resulting list of
exceptions is an intersection of the two lists of exceptions. For example, if an "Allow
All" policy is defined as "allow the use of all applications except Word, Excel and
PowerPoint" (=Word, Excel and PowerPoint cannot be used) is merged with a policy
defined as "deny the use of all applications except Word, Excel, Access and
Publisher" (=Word, Excel, Access and Publisher are allowed), then the result is "deny
the use of all applications except Access and Publisher".

A third combination principle is that positive exceptions are combined.

This means that if two "Deny All" policies with different exceptions are combined, then
the resulting list of exceptions becomes the combination of the two. For example, if a
policy is defined as "deny the use of all applications except Word and Excel" (=Word
and Excel are allowed) is merged with a policy defined as "deny the use of all
applications except PowerPoint" (=PowerPoint is allowed), then the result is "deny the
use of all applications except Word, Excel and PowerPoint".

Schematic overview of combination rules

The table below is a schematic overview of what happens when two policies are
combined. The table illustrates that:

· If one of the policies is a "Deny All" policy, then the resulting policy is also "Deny All":
Examples 1 through 4.

· When negative exceptions (=the exceptions in an "Allow All" policy) are combined with
positive exceptions (=the exceptions in a "Deny All" policy), the result to allow only the
exceptions that are in both except lists: Examples 2 and 3.

· When positive exceptions (=the exceptions in a "Deny All" policy) are combined with
positive exceptions, the result is to allow all exceptions from the two lists: Example 4.
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Exampl
e #

Source
policies

Source
exceptions

Resulting
policy

Resulting exceptions

1 Policy 1
Allow All

Apps 1 Allow All Except all applications in Apps
1 and Apps 2

Policy 2
Allow All

Apps 2

2 Policy 1
Deny All

Apps 1 Deny All Except applications in Apps 1
if they are not in Apps 2

Policy 2
Allow All

Apps 2

3 Policy 1
Allow All

Apps 1 Deny All Except applications in Apps 2
if they are not in Apps 1

Policy 2
Deny All

Apps 2

4 Policy 1
Deny All

Apps 1 Deny All Except applications in Apps 1
and Apps 2

Policy 2
Deny All

Apps 2

In the four examples below, the exceptions are substituted with actual application names.

Example 1:

Source policies Source
exceptions

Resulting policy Resulting exceptions

Policy 1
Allow All

Application1
Application2
Application3
Application4

Allow All Application1
Application2
Application3
Application4
Application5
Application6Policy 2

Allow All
Application1
Application2
Application5
Application6
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Example 2:

Source policies Source
exceptions

Resulting policy Resulting exceptions

Policy 1
Deny All

Application1
Application2
Application3
Application4

Deny All Application3
Application4

Policy 2
Allow All

Application1
Application2
Application5
Application6

Example 3:

Source policies Source
exceptions

Resulting policy Resulting exceptions

Policy 1
Allow All

Application1
Application2
Application3
Application4

Deny All Application5
Application6

Policy 2
Deny All

Application1
Application2
Application5
Application6

Example 4:

Source policies Source
exceptions

Resulting policy Resulting exceptions

Policy 1
Deny All

Application1
Application2
Application3
Application4

Deny All Application1
Application2
Application3
Application4
Application5
Application6Policy 2

Deny All
Application1
Application2
Application5
Application6
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sequence, install     4

set up terminal server     36

setup type     5, 6

setup wizard     10
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system info     40
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